News:博客小程序已成功发布,各位可以自行搜索使用,方便随时查找知识。

易语言实现时间和秒互相转换

忧郁之子 1084 0 条

E.jpg
提示:用到了精易模块

.版本 2

.子程序 功能_时间到秒, 整数型
.参数 参_时间, 文本型
.局部变量 局_累计时间, 整数型
.局部变量 局_正则, 正则表达式类

.如果真 (寻找文本 (参_时间, “天”, , 假) ≠ -1)
    局_正则.创建 (“(\d+)天(\d+)小时(\d+)分(\d+)秒”, 参_时间, )
    局_累计时间 = 到数值 (局_正则.取子匹配文本 (1, 1)) × 86400
    局_累计时间 = 到数值 (局_正则.取子匹配文本 (1, 2)) × 3600 + 局_累计时间
    局_累计时间 = 到数值 (局_正则.取子匹配文本 (1, 3)) × 60 + 局_累计时间
    局_累计时间 = 到数值 (局_正则.取子匹配文本 (1, 4)) + 局_累计时间
    返回 (局_累计时间)
.如果真结束

.如果真 (寻找文本 (参_时间, “小时”, , 假) ≠ -1)
    局_正则.创建 (“(\d+)小时(\d+)分(\d+)秒”, 参_时间, )
    局_累计时间 = 到数值 (局_正则.取子匹配文本 (1, 1)) × 3600
    局_累计时间 = 到数值 (局_正则.取子匹配文本 (1, 2)) × 60 + 局_累计时间
    局_累计时间 = 到数值 (局_正则.取子匹配文本 (1, 3)) + 局_累计时间
    返回 (局_累计时间)
.如果真结束

.如果真 (寻找文本 (参_时间, “分”, , 假) ≠ -1)
    局_正则.创建 (“(\d+)分(\d+)秒”, 参_时间, )
    局_累计时间 = 到数值 (局_正则.取子匹配文本 (1, 1)) × 60
    局_累计时间 = 到数值 (局_正则.取子匹配文本 (1, 2)) + 局_累计时间
    返回 (局_累计时间)
.如果真结束

.如果真 (寻找文本 (参_时间, “秒”, , 假) ≠ -1)
    局_正则.创建 (“(\d+)秒”, 参_时间, )
    局_累计时间 = 到数值 (局_正则.取子匹配文本 (1, 1))
    返回 (局_累计时间)
.如果真结束

返回 (局_累计时间)

.子程序 功能_秒到时间, 文本型
.参数 参_时间, 整数型
.局部变量 局_天, 整数型
.局部变量 局_小时, 整数型
.局部变量 局_分, 整数型
.局部变量 局_秒, 整数型
.局部变量 局_累计时间, 文本型

局_天 = 到整数 (参_时间 ÷ 86400)
局_小时 = 到整数 (到整数 (参_时间 - 局_天 × 86400) ÷ 3600)
局_分 = 到整数 (到整数 (参_时间 - 局_天 × 86400 - 局_小时 × 3600) ÷ 60)
局_秒 = 到整数 (参_时间 - 局_天 × 86400 - 局_小时 × 3600 - 局_分 × 60)
.如果真 (局_天 > 0)
    局_累计时间 = 局_累计时间 + 到文本 (局_天) + “天”
.如果真结束

.如果真 (局_小时 > 0)
    局_累计时间 = 局_累计时间 + 到文本 (局_小时) + “小时”
.如果真结束

.如果真 (局_分 > 0)
    局_累计时间 = 局_累计时间 + 到文本 (局_分) + “分”
.如果真结束

.如果真 (局_秒 > 0)
    局_累计时间 = 局_累计时间 + 到文本 (局_秒) + “秒”
.如果真结束

返回 (局_累计时间)

来源:精易论坛
原地址:https://bbs.125.la/thread-14583528-1-1.html

发表我的评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
欢迎光临轩宇网工作室