News:这是一个新的Typecho主题,如果使用问题请反馈给我QQ1989473781

使用易语言实现屏幕取色功能

忧郁之子 6568 0 条

屏幕取色.png

.版本 2
.支持库 eAPI
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 是否, 逻辑型

.子程序 __启动窗口_创建完毕

.子程序 _图片框1_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

.如果真 (取反 (是否))
    图片框1.鼠标指针 = #鼠标指针
    图片框1.图片 = #捕获鼠标
    处理事件 ()
    捕获鼠标 (图片框1.取窗口句柄 ())
    是否 = 真
.如果真结束

.子程序 _图片框1_鼠标左键被放开, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

.如果真 (是否 = 真)
    释放鼠标 ()
    图片框1.鼠标指针 = {  }
    图片框1.图片 = #释放鼠标
    是否 = 假
.如果真结束

.子程序 _图片框1_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型
.局部变量 R, 整数型
.局部变量 G, 整数型
.局部变量 B, 整数型

.如果真 (是否 = 真)
    取当前鼠标处颜色值 (R, G, B)
    图片框2.背景颜色 = 取颜色值 (R, G, B)
    编辑框1.内容 = 到文本 (图片框2.背景颜色)
    编辑框2.内容 = 取十六进制文本 (图片框2.背景颜色)
    编辑框3.内容 = 到文本 (R) + “,” + 到文本 (G) + “,” + 到文本 (B)
    编辑框4.内容 = “#” + 取十六进制文本 (R) + 取十六进制文本 (G) + 取十六进制文本 (B)
    编辑框5.内容 = “0x” + 取文本 (图片框2.背景颜色, )

.如果真结束

源码下载:本地下载

发表我的评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
欢迎光临轩宇网工作室