News:博客小程序已成功发布,各位可以自行搜索使用,方便随时查找知识。

高级表格 单独提取 批量提取 例子

忧郁之子 496 0 条
.版本 2
.支持库 eGrid

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

初始化高级表格 ()

.子程序 初始化高级表格

高级表格1.置数据 (1, 1, 1, “12345”)
高级表格1.置数据 (2, 1, 1, “23456”)
高级表格1.置数据 (3, 1, 1, “23450”)
高级表格1.置数据 (4, 1, 1, “02345”)
高级表格1.置数据 (5, 1, 1, “72345”)
高级表格1.置数据 (6, 1, 1, “82345”)
高级表格1.置数据 (7, 1, 1, “92345”)
高级表格1.置数据 (8, 1, 1, “62345”)
高级表格1.置数据 (9, 1, 1, “23045”)
高级表格1.置数据 (10, 1, 1, “23145”)
高级表格1.置数据 (11, 1, 1, “23465”)
高级表格1.置数据 (12, 1, 1, “02345”)
高级表格1.置数据 (13, 1, 1, “24345”)
高级表格1.置数据 (14, 1, 1, “62345”)
高级表格1.置数据 (15, 1, 1, “72345”)
高级表格1.置数据 (16, 1, 1, “02345”)
高级表格1.置数据 (17, 1, 1, “23451”)
高级表格1.置数据 (18, 1, 1, “23452”)
高级表格1.置数据 (19, 1, 1, “32345”)
高级表格1.置数据 (20, 1, 1, “42345”)

.子程序 _组合框1_列表项被选择

编辑框1.内容 = 高级表格1.取数据 (组合框1.现行选中项 + 1, 1)

.子程序 _按钮1_被单击

提取程序 ()

.子程序 提取程序
.局部变量 临时文本, 文本型
.局部变量 计次, 整数型
.局部变量 结果, 文本型

.判断开始 (到整数 (编辑框2.内容) < 到整数 (高级表格1.行数 - 1) - 0)
    .计次循环首 (到整数 (编辑框2.内容), 计次)
        临时文本 = 高级表格1.取数据 (计次 + 0, 1)
        结果 = 结果 + 临时文本 + #换行符
        处理事件 ()
    .计次循环尾 ()
    编辑框3.内容 = 结果

.默认

.判断结束

运行效果图:
微信截图_20200608230656.png
来源:精易论坛
原地址:https://bbs.125.la/thread-14583342-1-1.html

发表我的评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
欢迎光临轩宇网工作室