News:博客小程序已成功发布,各位可以自行搜索使用,方便随时查找知识。

易语言|编辑框内容删除空行与空格例子

忧郁之子 2198 0 条

使用到精易模块
下载地址:http://ec.125.la/

.版本 2

.子程序 删除空行与空格, 文本型
.参数 输出文本内容, 文本型
.局部变量 文本内容, 文本型
.局部变量 正则表达式, 正则表达式类

文本内容 = 输出文本内容
正则表达式.创建 (“ ”, 文本内容, , , , )  ' 删除多余的空格
文本内容 = 正则表达式.替换 (“”)
正则表达式.创建 (“\n\r”, 文本内容, , , , )  ' 删除多余的空行
文本内容 = 正则表达式.替换 ()
返回 (文本内容)

效果图:
214627eiw4a904vwv5www0.jpg

发表我的评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
欢迎光临轩宇网工作室