News:博客小程序已成功发布,各位可以自行搜索使用,方便随时查找知识。

SendMessageA学习笔记

忧郁之子 305 0 条

请输入图片描述

1.SendMessageA取多行文本框行数

.版本 2
.DLL命令 取多行文本框行数, 整数型, , "SendMessageA", , 包括自动换行,返回行数
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息
    .参数 wParam, , , 第一个消息参数
    .参数 lParam, , , 第二个消息参数
用法:取多行文本框行数 (编辑框1.取窗口句柄 (), #EM_GETLINECOUNT, 0, 0)
''#EM_GETLINECOUNT=186
''#EM_GETLINE=196

2.SendMessageA取多行文本框某行文本
对近在眼前的暂时消化不了,自己的理解如下,请指教.

.版本 2
.DLL命令 取多行文本框某行文本, 整数型, , "SendMessageA", , 返回某行文本长度
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息
    .参数 wParam, , , 第一个消息参数
    .参数 lParam, 文本型, 传址, 第二个消息参数

用法:

.版本 2
.局部变量 a, 整数型
.局部变量 str, 文本型

str = 取空白文本 (256)
a = 取多行文本框某行文本 (编辑框1.取窗口句柄 (), #EM_GETLINE, 0, str)
' a=某行文本长度
str = 取空白文本 (a)
取多行文本框某行文本 (编辑框1.取窗口句柄 (), #EM_GETLINE, 0, str)
输出调试文本 (str)

3.SendMessageA,弹出收起组合框列表

.版本 2
.DLL命令 弹出收起组合框列表, 整数型, , "SendMessageA"
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息
    .参数 wParam, 逻辑型, , 第一个消息参数
    .参数 lParam, , , 第二个消息参数

用法:

.版本 2
.子程序 _按钮1_被单击
弹出收起组合框列表 (组合框1.取窗口句柄 (), 335, 真, 0)
延时 (500)
弹出收起组合框列表 (组合框1.取窗口句柄 (), 335, 假, 0)
CB_SHOWDROPDOWN = 335

4.SendMessageA置列表框横向滚动条

.版本 2
.DLL命令 置列表框横向滚动条, , , "SendMessageA"
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息
    .参数 wParam, , , 第一个消息参数
    .参数 lParam, , , 第二个消息参数
置列表框横向滚动条 (列表框1.取窗口句柄 (), 404, 250, 0)

测试失败。。。。。。

5.SendMessageA置文本框只读属性

.版本 2
.DLL命令 置文本框只读属性, , , "SendMessageA"
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息
    .参数 wParam, 逻辑型, , 第一个消息参数
    .参数 lParam, , , 第二个消息参数
.版本 2
.子程序 _按钮1_被单击
' EM_SETREADONLY = 207
置文本框只读属性 (编辑框1.取窗口句柄 (), 207, 真, 0)

6.

.版本 2
'' SendMessage(TreeView1.hwnd, TVM_SETBKCOLOR, 0, RGB(255, 0, 0))
置树形框背景颜色 (树型框1.取窗口句柄 (), 4381, 0, 124545)
'' SendMessage(TreeView1.hwnd, TVM_SETITEMHEIGHT, 60, 0)
置树形框项目行高 (树型框1.取窗口句柄 (), 4379, 30, 0)

7.SendMessageA取文本框修改状态

.版本 2
.DLL命令 取文本框修改状态, 逻辑型, , "SendMessageA"
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息
    .参数 wParam, , , 第一个消息参数
    .参数 lParam, , , 第二个消息参数
.版本 2
' EM_GETMODIFY=184
输出调试文本 (取文本框修改状态 (编辑框1.取窗口句柄 (), 184, 0, 0))

8.SendMessageA取文本框密码文本

.版本 2
.DLL命令 置文本框密码属性, , , "PostMessageA", , 
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息
    .参数 wParam, , , 第一个消息参数
    .参数 lParam, , , 第二个消息参数
.版本 2
.DLL命令 取文本框文本长度, 整数型, , "SendMessageA"
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息
    .参数 wParam, , , 第一个消息参数
    .参数 lParam, , , 第二个消息参数
.版本 2
.DLL命令 取文本框文本, , , "SendMessageA"
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息
    .参数 wParam, , , 第一个消息参数
    .参数 lParam, 文本型, 传址, 第二个消息参数
.版本 2
' EM_GETPASSWORDCHAR=204
置文本框密码属性 (编辑框1.取窗口句柄 (), 204, 0, 0)
' WM_GETTEXTLENGTH=14
a = 取文本框文本长度 (编辑框1.取窗口句柄 (), 14, 0, 0)
str = 取空白文本 (a)
' WM_GETTEXT=13
取文本框文本 (编辑框1.取窗口句柄 (), 13, a + 1, str)
' 为什么要加1?
输出调试文本 (str)
' 42=取代码 (“*”, )
置文本框密码属性 (编辑框1.取窗口句柄 (), 204, 42, 0)

9.SendMessageA置进度条颜色

```go 
.版本 2
.DLL命令 置进度条颜色, 整数型, , "SendMessageA"
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息
    .参数 wParam, , , 第一个消息参数
    .参数 lParam, , , 第二个消息参数
置进度条颜色 (进度条1.取窗口句柄 (), 1033, 0, #红色)

10.SendMessageA关闭窗口

.版本 2
.DLL命令 关闭窗口, , , "SendMessageA"
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息16
    .参数 wParam, , , 第一个消息参数
    .参数 lParam, , , 第二个消息参数
关闭窗口 (_启动窗口.取窗口句柄 (), 16, 0, 0)

11.

清除窗口标题 (_启动窗口.取窗口句柄 (), 12, 0, 0)
清除窗口标题 (按钮1.取窗口句柄 (), 12, 0, 0)
移动窗口 (_启动窗口.取窗口句柄 (), 274, 61458, 0)
移动窗口 (标签1.取窗口句柄 (), 274, 61458, 0)
移动窗口 (按钮1.取窗口句柄 (), 274, 61458, 0)

12.SendMessageA取列表框鼠标所在表项

.版本 2
.DLL命令 取列表框鼠标所在表项, 整数型, , "SendMessageA"
    .参数 hwnd, , , 对象窗口句柄
    .参数 wMsg, , , 被发送的消息
    .参数 wParam, , , 第一个消息参数
    .参数 lParam, , , 第二个消息参数
.版本 2
.子程序 _列表框1_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型
' 来自[近在眼前-列表框动态显示]
输出调试文本 (取列表框鼠标所在表项 (列表框1.取窗口句柄 (), 425, 0, 横向位置 + 纵向位置 × 65536))

13.

.版本 2
.DLL命令 置单选框复选框选中状态, 整数型, , "SendMessageA"
    .参数 hwnd, , , 对象窗口句柄单选框、复选框
    .参数 wMsg, , , 被发送的消息241
    .参数 wParam, , , 第一个消息参数1=选中,0=未选中
    .参数 lParam, , , 第二个消息参数0
' 来自[近在眼前]

14.

.版本 2
.DLL命令 取列表框项目索引, 整数型, , "SendMessageA", , 可判断项目是否存在
    .参数 窗口句柄, 整数型, , 列表框句柄
    .参数 信息值, 整数型, , 418
    .参数 参数一, 整数型, , 0
    .参数 参数二, 文本型, , 项目文本
.DLL命令 取组合框项目索引, 整数型, , "SendMessageA", , 可判断项目是否存在
    .参数 窗口句柄, 整数型, , 组合框句柄
    .参数 信息值, 整数型, , 344
    .参数 参数一, 整数型, , 0
    .参数 参数二, 文本型, , 项目文本

与本文相关的文章

发表我的评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
欢迎光临轩宇网工作室